Opened 4 years ago

Closed 3 years ago

#324 closed defect (wontfix)

App built on Windows 7 does not run on XP.

Reported by: gh@… Owned by:
Priority: high Milestone: PyInstaller 1.5.2
Component: Platform Windows Version: 1.4
Severity: major Keywords: wxpython wxwebkit windows
Cc:

Description

I am building an app which uses wxWebkit and therefore wxControls. When I build it on Windows XP, it runs on all platforms. When I build it on Windows 7, it only runs on Windows 7. The Windows 7 build dies without any error message when run on WinXP.

I am using PyInstaller? 1.5 (but the same thing happened in 1.4), wxWebkit-win32-wx2.8-Py2.6-preview1, and wxPython2.8-win32-unicode-2.8.11.0-py26.exe.

I have attached a zip minimal project and my build batch file. The batch build file is:

rmdir /s/q build
rmdir /s/q dist
rmdir /s/q ..\Extensions\pyInstaller1.5\bincache00
del nsbasic.spec

"c:\program files\python26\python.exe" ..\..\extensions\pyInstaller1.5\Makespec.py -w  --name=Webview Webview.py

"c:\program files\python26\python.exe" ..\..\extensions\pyInstaller1.5\Build.py Webview.spec

Attachments (1)

Test.zip (8.0 KB) - added by gh@… 4 years ago.
Minimal files to recreate problem.

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by gh@…

Minimal files to recreate problem.

comment:1 Changed 3 years ago by matysek

  • Milestone changed from PyInstaller 1.5 to PyInstaller 1.6

comment:2 Changed 3 years ago by matysek

  • Owner changed from giovannibajo to matysek
  • Status changed from new to assigned

comment:3 Changed 3 years ago by matysek

  • Owner matysek deleted
  • Status changed from assigned to new

comment:4 Changed 3 years ago by htgoebel

  • Component changed from PyInstaller to Platform Windows

We changes a lot here for release 1.5.
Please test with either 1.5.1 or current development branch. Thanks.

comment:5 Changed 3 years ago by matysek

  • Milestone changed from PyInstaller 2.0 to PyInstaller 1.5.2

Development branch should work. I think this should be fixed in 1.5.2 branch.

comment:6 Changed 3 years ago by matysek

  • Resolution set to wontfix
  • Status changed from new to closed

The develop branch should work. We decided to drop 1.5.2 and focus rather on 2.0.

Note: See TracTickets for help on using tickets.